Skip to content

Installing WordPress

In order to be installed, the theme requires that you have a working WordPress installation, locally or on you web space.

If you need help installing WordPress, you can head over to the official WordPress documentation page to get started.

If this is your first time using WordPress, you can also take a look at a few other pages that might help you understand the basics:

Technical requirements

To use the theme, the minimum WordPress version required is 4.4. From the technical point of view, your host must support at least the following:

  • PHP 5.2+
  • MySQL 5+

Concerning PHP, even if the minimum version required is 5.2, we strongly encourage that you use a newer version, such as 5.5 or 5.6, both for performance and security reasons. If you’re not yet on those, talk to your host and enquire about the possibility of activating one of those versions on your account.

Suggested PHP configuration settings

Every once in a while, you might encounter a problem that is somehow related to the configuration of the PHP that’s running on your host. In order to try to prevent those errors from happening, we suggest that you make sure that you have the following settings in place:

  • max_execution_time: 180
  • memory_limit: 96M
  • post_max_size: 32M
  • upload_max_filesize: 32M

Suggested WordPress configuration settings

In order to increase the memory allocated to your WordPress installation, you also need to follow these steps to set a specific memory limit.